WordPress: Updating Your PHP Version Successfully

For Web Hosting packages

Learn how to change the PHP version running your WordPress website and what you need to keep in mind when switching to a newer PHP version.

Please Note

For Managed WordPress installations, we take care of the PHP administration for you and make sure that your website uses a current PHP version and that all components work perfectly with that version of PHP. Accordingly, manual configuration of the PHP version is not necessary for Managed WordPress.

What is PHP?

PHP is a programming language that runs on the web server. It is mainly used to create dynamic web pages or web applications. For example, all WordPress websites run on PHP.

When does it make sense to change PHP versions?

Like WordPress, PHP is constantly being developed and improved, so operators of a WordPress website may experience one of the following situations that require changing the PHP version:

  • A WordPress update requires a newer version of PHP.
  • A certain version of PHP is outdated and should not be used anymore.
  • A new version of PHP has been released and includes performance enhancements you want to benefit from.

Which version should I use?

You can choose between different PHP versions. If there is no particular reason for a particular version, you should use the recommended version in your PHP administration. Currently this is PHP 7.4. With this version, you can use the most popular and proven applications without further compatibility problems.

Changing Your PHP Version

Technically, you only need a few mouse clicks to change your domain - and thus the WordPress website - to a new PHP version. However, it is possible that the WordPress version used, individual plug-ins, or the WordPress theme are not yet fully compatible with the new PHP version. In order to avoid any resulting malfunctions, we suggest that you prepare the website for the change of the PHP version first, and then change the PHP version. We recommend using the following procedure when switching to a new PHP version:

    • Create a Backup

      Before changing the PHP version, you should back up your WordPress website so you are prepared for all events and can restore the old state of the website at any time if necessary.

    • Update WordPress

      The older your WordPress version is, the more likely it is that the PHP program code you are using is no longer compatible with the new PHP version. Check if updates are available for your WordPress version, plugins and theme. Unless you need to use an older version of WordPress for some reason, you should always keep your WordPress and all components up to date because these updates also regularly close security vulnerabilities.

    • Check the Compatibility of Themes and Plug-ins

      If you are using third-party plug-ins, you can check in advance if it is compatible with the newer PHP version by opening the official WordPress plug-ins page, searching for the plug-ins you are using, and then looking in the details for information about the supported PHP versions, or more conveniently by using the free PHP Compatibility Checker plug-ins, which can be installed using the WordPress plug-ins management. The installed plugins and themes can then be tested for compatibility with different PHP versions. To test compatibility with PHP 7.4, click Start Scan, select PHP 7.4 and click Scan site to start the scan. You will then receive an overview with the details of the scan.
    • Change PHP version

      After you have made all the preparations, you can change your domain to the desired PHP version. Activating the new PHP version only takes a few minutes. Click here to change the PHP version for your domain
    • Check the Website for Errors

      As soon as the new PHP version is active, you should immediately check the website thoroughly:
      - Is the website accessible?
      - Are all subpages accessible?
      - Do all sliders, galleries, forms etc. work?
      - Does the backend (administration area) work?

    Additional Notes

    If there are problems with the new PHP version, it is recommended to check all plug-ins again for compatibility. You may need to uninstall or replace incompatible plug-ins with other similar options.

    In order to restore the availability of the website - or the backend - as quickly as possible in the event of a problem, you can switch the domain back to the previous PHP version. Note that it may take a few minutes after the changeover for this PHP version to become active again. If errors occur with the old version as well, you will have to restore your website from the backup.